Increase in TrustedForm Latency

Incident Report for ActiveProspect

Resolved

High latency observed from 6:40 AM–8:20 AM CDT.
Issue has been resolved and systems are operating normally.
Posted Sep 30, 2025 - 04:30 CDT