LeadConduit Classic elevated HTTP 502 rate on lead submission
Incident Report for ActiveProspect
Resolved
Over the last few days, we've made several infrastructure changes to address the increased error rate on LeadConduit Classic lead submission. Those changes have dramatically reduced the number of HTTP 502s that the API is returning. We have one more change that we think will further improve things, but are going to mark this resolved since the number of errors is so low already.
Posted Nov 25, 2019 - 15:58 CST
Update
A set of configuration changes yesterday reduced the error rate, and we added additional capacity last night. The number of 502 errors is down, but not zero. We are continuing to monitor this issue and make adjustments.
Posted Nov 22, 2019 - 10:04 CST
Monitoring
We've identified and fixed one issue, but continue to monitor system performance.
Posted Nov 20, 2019 - 19:46 CST
Investigating
Over the last few days we have been tracking a slightly elevated number of HTTP 502 responses being returned by the LeadConduit Classic lead submission API. We are have been troubleshooting and will update once we have identified the issue and again once the matter has been resolved.

As always, if you receive a HTTP status code of anything other than 200 when submitting leads, the submission must be retried.
Posted Nov 20, 2019 - 13:21 CST
This incident affected: LeadConduit Classic.