Degraded performance for TrustedForm Certify on several sites

Incident Report for ActiveProspect

Resolved

This incident has been resolved by rolling TrustedForm Script back to 1.9.4. We will continue investigation on issues caused by the latest version of the script.
Posted Mar 28, 2024 - 16:58 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2024 - 16:29 CDT

Update

Rolling back TrustedForm Script to 1.9.4
Posted Mar 28, 2024 - 16:16 CDT

Investigating

We've received issues from 3 clients that the TrustedForm Script has not been working properly since around 3p CT on March 27th. Currently investigating and assessing impact.
Posted Mar 28, 2024 - 15:25 CDT
This incident affected: TrustedForm Certify.