TrustedForm Certificate Issuer Incident
Incident Report for ActiveProspect
Resolved
TrustedForm has been processing normally since 9a CDT.
Posted Mar 30, 2023 - 14:56 CDT
Monitoring
TrustedForm is now operating normally. We will continue to monitor it and investigate the impact of this incident.
Posted Mar 30, 2023 - 10:10 CDT
Investigating
We are currently investigating an ongoing issue that is negatively impacting our TrustedForm application's ability to create new certificates.
Posted Mar 30, 2023 - 09:05 CDT
This incident affected: TrustedForm Application and TrustedForm Certify.