TrustedForm is down
Incident Report for ActiveProspect
Resolved
TrustedForm is operating at 100%. The claim API was down from approximately 12:50pm central to 1:30pm. There are no other impacts from this outage. If you see something strange or have further questions, please reach out to support@activeprospect.com.

We're still working through what happened with the cluster and we will take whatever action is necessary to prevent this from occurring again. Again, we really appreciate your patience during this outage. Thank you.
Posted Jan 08, 2020 - 14:05 CST
Monitoring
The database cluster repair has completed. Certificates generated during this outage appear to be properly formed. We are not seeing any evidence of data loss. If you are calling the TrustedForm claim API directly from your system, you will need to retry all claim calls that did not result in an HTTP 201. This is always the case, even when we aren't having a major service interruption such as this. If you are processing leads through LeadConduit, all your failed claim calls will be automatically retried for you. There is non further action necessary on your part.

We are continuing to monitor the health of the system. Once we are confident that it is fully recovered, we will mark this issue resolved.
Posted Jan 08, 2020 - 13:37 CST
Update
The cluster is currently repairing itself. At the current rate, we hope to see the repair complete within 15 minutes. The service may be operable before then. We will share additional updates as soon as we have them. Thank you for your patience while the team works through this issue.
Posted Jan 08, 2020 - 13:31 CST
Investigating
We are currently investigating a service outage caused by a failed database cluster. We're working on restoring that cluster to full operation currently, but don't yet know a timeline. Once we have done so, we expect the service to be back up and running at full capacity.
Posted Jan 08, 2020 - 13:15 CST
This incident affected: TrustedForm Application and TrustedForm Certify.