TrustedForm claim problems
Incident Report for ActiveProspect
Resolved
A delay was detected in the time between when certificates were issued and when they became available. No data was lost. You may re-claim any certificates previously came back as errors.
Posted Jun 24, 2016 - 11:52 CDT
Investigating
Claims of TrustedForm certificates are failing, we're investigating.
Posted Jun 24, 2016 - 11:27 CDT