TrustedForm degraded performance
Incident Report for ActiveProspect
Resolved
TrustedForm is now responding normally. Our team continues to look into the root cause of the slowness.
Posted Sep 02, 2014 - 11:31 CDT
Investigating
We are currently investigating timeouts and slowness currently ongoing with TrustedForm due to high load.
Posted Sep 02, 2014 - 10:56 CDT